当前位置: 首页 > 系统教程 > 虚拟化教程 > 详细页面

如何更改VMware虚拟机的硬件兼容性

时间:2017-08-03 22:33来源:VMware官网 作者:admin

您可以更改虚拟机的硬件兼容性。所有虚拟机都具有硬件版本。硬件版本指明了虚拟机支持的虚拟硬件功能(如 BIOS 或 EFI)、虚拟插槽数量、最大 CPU 数、最大内存配置,以及其他硬件特性。
升级 Workstation Pro 时,必须更改使用以前版本的 Workstation Pro 创建的虚拟机的硬件兼容性,以使这些 虚拟机能够使用新版 Workstation Pro 中的新功能。您可以在新版 Workstation Pro 中运行旧版虚拟机,但是 无法使用新功能。
如果您希望虚拟机与自己所使用的其他 VMware 产品保持兼容,就有可能不希望针对最新版 Workstation Pro 更改硬件兼容性。
注意 如果您决定不更改虚拟机的硬件兼容性,应考虑升级到最新版 VMware Tools,以便利用 VMware Tools 的最新功能。
前提条件
熟悉更改虚拟机硬件兼容性的注意事项和限制。请参见第 26 页,“更改虚拟机硬件兼容性的注意事项”。
步骤
1 制作虚拟磁盘 (.vmdk) 文件的备份副本。
2 如果从 Workstation 5.x 虚拟机向更高版本升级,或从更高版本降级到 Workstation 5.x 虚拟机,请记下客 户机操作系统中的网卡设置。 如果已为虚拟机指定了静态 IP 地址,则升级后该设置可能会改为由 DHCP 自动分配。
3 关闭客户机操作系统和虚拟机。
4 选择虚拟机,然后选择虚拟机 > 管理 > 更改硬件兼容性。
5 根据向导中的提示更改虚拟机的硬件兼容性。 在选择硬件兼容性设置时,系统会显示与该设置相兼容的 VMware 产品列表。例如,如果选择 Workstation 4、5 或 6,系统还会显示该 Workstation 版本不支持的 Workstation 6.5 及更高版本的功能列表。
注意 使用 Workstation 10 时,可以更改共享或远程虚拟机的硬件兼容性,但不能降级先前创建的虚拟机。
6 开启虚拟机。 如果将包含 Windows 98 操作系统的虚拟机升级到 Workstation 6.5 或更高版本的虚拟机,在开启虚拟机 时必须安装 PCI-PCI 网桥驱动程序。 注意 这是因为 Workstation 6.5 及更高版本的虚拟机比 Workstation 6 多了 32 个 PCI-PCI 网桥,您可能 需要对提示作出 32 或 33 次响应。
7 如果客户机操作系统中的网卡设置已更改,请根据您记录的网卡设置将其更改回原始设置。
8 如果虚拟机未安装最新版 VMware Tools,请更新 VMware Tools。 即使将虚拟机升级到早期版本的 Workstation Pro,也应将 VMware Tools 更新为最新版 Workstation Pro 所含的版本。请勿在安装新版本前移除旧版 VMware Tools。 注意 在升级从物理磁盘运行的虚拟机时,您可以安全地忽略以下消息:无法升级 drive_name。所提供的参 数中,其中一个参数无效。

更改虚拟机硬件兼容性的注意事项
在更改虚拟机的硬件兼容性之前,您应了解特定注意事项和限制。
n 对于 Workstation 5.x、6、6.5、7.x 和更高版本的虚拟机,您可以更改原始虚拟机的版本,或者创建完整 克隆使原始虚拟机保持不变。
n 如果将与 ESX Server 兼容的 Workstation 5.x 虚拟机升级到 Workstation 6、6.5、7.x 或更高版本,则以后 您将无法使用更改硬件兼容性向导将虚拟机降级到兼容 ESX 的虚拟机。
n 升级 Windows XP、Windows Server 2003、Windows Vista、Windows 7 或 Windows 8 虚拟机时, Microsoft 产品激活功能可能会要求您重新激活客户机操作系统。
n 使用 Workstation 9 或更早版本时,无法更改共享或远程虚拟机的硬件兼容性。
n 使用 Workstation 10 及更高版本时,可以更改共享或远程虚拟机的硬件兼容性,但不能降级先前创建的虚 拟机。